Fillable PDF's MUST be filled out using Adobe Acrobat or Adobe Reader  version 9 or greater.